Port Forwarding icm Synology NAS212 (VPN L2TP/IP-SEC)


Hans263

Forum Gebruiker
Lid geworden
29 jun 2011
Berichten
6
Ziggo
Alles in 1
Gebied
fZiggo
Ik snap er niks meer van. Ik heb VPN server op mijn NAS (Synology212) ingesteld als L2TP/IPSec. Hiervoor moeten de poorten 500,1701 en 4500 (UDP) worden geforward in mijn Ubee3200 Modem-Router. Heb een statisch adres voor mijn NAS opgegeven. Dat heb ik volgens mij goed gedaan, echter probleem is dat bij port-scan van buiten deze poorten niet als 'zichtbaar' worden bevonden. Layout: Gateway (Via Ubee3200) en hierop direct NAS212. Instelling via I-phone meldt dat De L2TP-VPn server niet reageert. Ik vrag me af of er in de UBEE-3200 iets verkeerd is ingesteld waardoor deze de poorten niet open zet. Wie herkent dit en heeft een gouden tip? Overzicht van poorten zie bijlage.
UBEE-4200.JPG
 
Laatst bewerkt:

PetervdM

Forum Gebruiker
Lid geworden
27 nov 2008
Berichten
486
Ziggo
Alles in 1
Gebied
fZiggo
heb je vinkjes gezet bij gateway, options, en dan Ipsec PassThrough en PPTP PassThrough?
waarschijnlijk kun je dan ook de port forwardings weghalen.
om ipsec te kunnen laten werken moet je nl ook protocol esp ( 50 ) doorlaten, en dat kan niet in het port forwarding scherm. daar heb je alleen tcp ( 6 ) en udp ( 17 )
 
Laatst bewerkt:

René

Moderator
Lid geworden
13 okt 2001
Berichten
7.340
Ziggo
Internet & Televisie
Gebied
fUPC
Dat de UDP poorten niet reageren klopt. Die kun je namelijk niet scannen.
Volgens mij ging l2tp/ipsec niet werken omdat die naast tcp en udp ook protocol 50 gebruikt. Iets wat niet zomaar geforward kan worden. Wat PetervdM zegt, even controleren of vpn passthrough aanstaat.
En is anders openvpn een optie? Die gaat beter om met firewalls.
 

Briolet

Forum Gebruiker
Lid geworden
14 aug 2012
Berichten
3.380
Ziggo
Alles in 1
Gebied
fZiggo
Ik heb ook de Ubee 3200 en nog nooit problemen gehad met L2TP/IP-sec dat ook mij mij op een Synology nas draait. De instellingen in dat screenshot zijn correct, mits dat het IP adres van de nas is.

En edit je eerste post, want er staan nu heel verwarrende versienummers in. Een Ubee 4200 is er bij mij weten nooit geweest bij Ziggo.
 
Topicstarter
Topicstarter
Hans263

Hans263

Forum Gebruiker
Lid geworden
29 jun 2011
Berichten
6
Ziggo
Alles in 1
Gebied
fZiggo
Heren, dank alvast voor jullie reactie. @peter: Vinkjes IPsec passtrough en PPTP passtrough staan aan bij Gateway options (stonden ook al aan). Heb de port forwarding rules 500, 1701 en 4500 weggehaald. Resultaat blijft hetzelfde. Voor alle duidelijkheid, ik probeer te testen met I-phone. Vraag: Op welke manier (tool?) kan ik testen of de verbinding via de router goed loopt. Als dat namelijk t geval is, dan is er iets anders wat roet ih eten gooit. @Briolet: Heb tekst aangepast hoor, en als jij min of meer dezelfde configuratie hebt, dan ben ik benieuwd of er ook andere instellingen in de UBEE bij mij misschien verkeerd staan. @Rene: VPN passtrough is geen aparte optie bij gateway options.
 

Briolet

Forum Gebruiker
Lid geworden
14 aug 2012
Berichten
3.380
Ziggo
Alles in 1
Gebied
fZiggo
Je router staat goed. Heb je in het VPN-log op de nas gekeken? Dan zie je misschien of er wel contact was.

Staat de firewall op de nas wel goed? Zet hem anders tijdelijk geheel uit, om dit uit te sluiten.

Er zijn wel sites waar je UDP poorten mee kunt testen, maar dat is allemaal onzin. Als je de forwards instelt en de firewall op de nas, is er geen reden om ook nog te testen of je dat ingesteld hebt.

Je moet wel van buiten je LAN testen. Ik gebruik daar vaak mijn eigen WifiSpot voor, want voor de nas is dat ook een externe verbinding.