1. Welkom op het onafhankelijke Ziggo Gebruikersforum. Een forum voor en door gebruikers van Ziggo.
    Registreer je gratis om direct zelf berichten te plaatsen en gebruik te maken van extra functies!
    Verberg deze melding

Hostnaam linkt niet naar mijn (externe) IP-adres

Discussie in 'Internet - Algemeen' gestart door bartgrefte, 23 mei 2009.

Niet open voor verdere reacties.
  1. Heey!

    Ben er vandaag achtergekomen dat mijn huidige hostnaam niet linkt naar mijn IP-adres.

    Als ik naar www.watismijnip.nl ga, dan zie ik het volgende:
    Doe ik start->uitvoeren->cmd->tracert "mijn-IP", zie ik dezelfde hostnaam.
    Maar doe ik dan een tracert naar die hostnaam, dan krijg ik een totaal ander IP adres (94.215.**.***) te zien die, aldus diezelfde tracert, een andere hostnaam heeft: *ED**C*E.cable.ziggo.nl.

    cc*******-b.zwoll1.ov.home.nl was overigens niet mijn originele hostnaam. Tot een paar maanden geleden was die cc******-c.ensch1.ov.home.nl. Deze is (volgensmij tijdens werkzaamheden) op 12 feb. aangepast naar die nieuwe en op datzelfde moment ging ik van 82.75.***.** naar de 82.74.***.*** reeks.

    Nou heeft bovenstaande geen problemen opgeleverd verder, alleen werkt BPFTP-server niet meer in passive modus (niet zo heel erg) omdat de hostnaam niet naar mijn IP linkt. Met dank aan BPFTP-server ben ik daar overigens achtergekomen, stond oude hostnaam nog in, na aanpassen en op test geklikt te hebben zag ik het vreemde IP-adres...


    Iemand enig idee wat er hier aan de hand is? Vind het maar vaag/vreemd:?

    Groetjes!

    Bart Grefte
     
  2. Wat zijn de DNS-server(s) die je gebruikt. Ziggo is erg bang van opendns, en adverteert eigen dns-servers. Ikzelf gebruik Treewalk (ICANN root) met voormalige multikabel, greenbv en opendns backup. Wanneer je braaf Ziggo DNS servers gebruikt loop je voortdurend de kans naar "eigen" IP-nummers gestuurd te worden die niet overeenkomen met IP-nummers via externe internet benadering. Nadelen van mijn opzet heb ik nog niet kunnen vinden; wel het voordeel van heel snelle DNS-lookup (al behoort ziggo ook niet tot de treuzelaars).

    Vergeet je trouwens niet per ongeluk dingen die je misschien heel vroeger in je hosts of lmhosts files gezet hebt?

    Mees de Roo
     
    Laatst bewerkt door een moderator: 23 mei 2009
  3. De vaste eigen-hostnaam bestaat niet meer. Dat was ooit alleen bij @home. Casema en Multikabel hadden dat al nooit. Bij veel @home mensen is dat nu ook niet meer hetzelfde als ze een ander ip-adres krijgen. Dus ik vermoed dat het binnenkort daar ook helemaal losgekoppeld is.
     
  4. Ja CeeS, maar als ik dit verhaal goed begrijp, krijgt bartgrefte afhankelijk van de manier waarop hij zijn IP-adres benadert twee totaal verschillende IP-adressen tegelijkertijd voor één en dezelfde aansluiting. Nu kan dat een raar overblijfsel uit de @home tijd zijn, of grote time-to-live-verschillen tussen diverse DNS-servers, maar erg gezond is dat toch niet.

    Mees de Roo
     
  5. OpenDNS, verder nooit problemen mee gehad, tot nu dan.
    Maar enigste die er last van heeft is passive mode van BPFTP:?

    Host/lmhosts files heb ik nooit wat in gezet...

    edit: moet ik het wel goed zeggen.
    Op de pc's heb ik, naast vast IP, OpenDNS ingesteld. De router daarentegen staat op automatisch, dus die gebruikt die van Ziggo.

    Hmm crap.
     
  6. Inderdaad, ik had de essentie van de vraag niet helemaal goed opgepikt :wink:

    Bij @home hadden klanten een vaste hostnaam, maar niet persé een vast ip-adres. Soms kregen ze een nieuw ip-adres en werd automatisch de hostnaam na enige tijd weer aangepast naar de oude hostnaam. Die stond dan soms een paar dagen fout om dan weer goed te komen.

    Nu is er blijkbaar iets niet goed gegaan, want ik zie inderdaad hetzelfde bij het ip-adres van "bartgrefte" (wat ik als forumadmin kan zien). Bij zijn 87.x.x.x. adres hoort een hostnaam en als ik naar die hostnaam een traceroute doe kom ik uit bij een 94.x.x.x adres die een cable.ziggo.nl hostnaam heeft. Het lijkt dus of zijn hostnaam nog op het oude-ip-adres staat. Misschien komt dat dus na een paar dagen weer goed als in zijn gebied het nog op de oude manier werkt.
     
  7. Ok, bartgrefte, je directe antwoord heb je in ieder geval binnen (bedankt CeeS :) ).
    DNS was hier dus niet direct de schuldige.
    Nog even over openDNS.
    Je realiseert je dat je met openDNS servers op 1/2 een vrij groot risico op false positives hebt? Die servers kennen het woord "bestaat-niet" niet.
    Verder zijn ze vrij traag in vergelijking met klassieke servers in de buurt.
    Google eens naar Treewalk. Snel en strikt conform ICANN antwoorden.

    Mees de Roo
     
  8. Jep :), thanks CeeS!

    False positives? Weet wel wat je bedoeld, maar hoe moet ik dat zien bij internet/OpenDNS?
    Euh als er iets niet bestaat, krijg ik gewoon een melding van OpenDNS van dat ie de site niet kan vinden, lijkt me niks vreemds aan.

    Heb niks van traagheid gemerkt, iig niet als ik vergelijk met toen ik nog Ziggo's DNS servers ingesteld had.

    Zal daar eens een keer naar kijken, thanks voor de tip ;)
     
  9. Gebruik onderstaande benchmark om snelheid van dns-servers te testen. Let daarbij op de opmerkingen bij opendns.

    http://www.grc.com/dev/dnsbench.exe

    opendns corrigeert typefouten; de definitie van een typefout is een niet-gevonden adres, terwijl er een adres is dat daar op lijkt en dat wel bestaat.
    Soms corrigeren ze een echte typefout. Soms krijg je iets waar je niet om gevraagd hebt.
    Ik gebruik ze wel, maar ergens heel onderaan de rij van dns-servers (if al else fails).
    Het probleem dat bovenliggende dns-servers dan al lang "bestaat-niet" hebben geroepen heb ik weten op te lossen door TTL van caching voor alle types negatieve antwoorden op 0 te zetten. Omdat snort bezwaar maakt tegen de TTL=1 van opendns (nog een oorzaak van traagheid) kan ik zien dat ze, ondanks dat ze als 11 en 12 in de rij staan, toch soms gebruikt worden.

    Mees de Roo
     
    Laatst bewerkt door een moderator: 24 mei 2009
  10. Aangezien we het hier over hostnamen hebben en ik daar een vraag gerelateerd aan heb, lijkt het me handiger hier gewoon een reactie te plaatsen ipv een nieuw topic aan te maken.


    Anyhoo, ik ben sinds vandaag ook gebruiker van Ziggo Internet, maar ik heb hiervoor altijd internet van xs4all gehad. Daar had ik de mogelijkheid om mijn hostnaam aan te passen naar iets eigens. Ik lees nu dat Ziggo de hostnamen niet meer gebruikt voor de verbindingen, dus is het mogelijk om mijn hostnaam zelf te veranderen, wellicht ergens online in Mijn Ziggo of iets dergelijks¿

    Of is dit alles nog te vers om met dit soort mogelijkheden te komen....¿
     
Niet open voor verdere reacties.

Deel Deze Pagina