1. Welkom op het onafhankelijke Ziggo Gebruikersforum. Een forum voor en door gebruikers van Ziggo.
    Registreer je gratis om direct zelf berichten te plaatsen en gebruik te maken van extra functies!
    Verberg deze melding

opbouw homepage

Discussie in 'Internet - Algemeen' gestart door Arnoldus, 14 dec 2008.

Niet open voor verdere reacties.
  1. Het is mij niet duidelijk of ik op het juiste forum ben.
    Bij veel homepages zie je de inhoud van de directory.
    Dit kan nooit de bedoeling zijn.
    In troublesathome stond ooit de oplossing.
    Plaats een leeg bestandje met de naam 'index.html' in de betreffende directory. Daarmee verhinder je dat de inhoudsopgave van die derectory wordt getoond.
    Voor mij is deze informatie te weinig, want met een lege index-pagina kom ik dus niet verder dan deze pagina.
    Hoe moet nu de link naar de 'default.html'-pagina worden gemaakt.
    Bij voorbaat dank.
     
  2. Je default pagina moet je dus gewoon "index.html" noemen.
     
  3. Nee, er staat helemaal geen index.htm of index.html op je homepage, daarom zie je de bestanden staan. De meeste webservers laten standaard een bestandenlijst zien als je geen index.htm of index.html hebt.

    Als de bedoeling is dat 'ajmterbruggen.htm' de pagina is die de mensen standaard moeten krijgen, zul je deze de naam index.htm of index.html moeten geven.
     
  4. Je moet het bestand ajmterbruggen.htm renamen naar index.htm
    dan werkt het...
     
  5. Plaats deze regel in index.htm


    <html>
    <head>
    <title>index</title>
    <meta http-equiv="refresh" content="0; URL=ajmterbruggen.htm">
    </head>
    <body>
    </body>
    </html>
     
    Laatst bewerkt door een moderator: 14 dec 2008
  6. Dat is om een doorverwijzing te maken, maar dat was blijkbaar niet zijn probleem, want hoe hij een standaard html pagina kreeg wist hij al.

    Ik heb ondertussen via PB een paar berichten met Arnoldus uitgewisseld en zijn vraag was eigenlijk: hoe zorg ik ervoor dat een directory niet bekeken kan worden. Vooral in submappen kan iemand door alleen de mapnaam in te voeren de inhoud zien van die map op de homepageserver van ziggo/@home.

    Oplossing:
    Door in elke map die je gebruikt een bestand met de naam index.htm of index.html op te nemen (met bijvoorbeeld alleen een spatie erin) voorkomt je dit. (het niet tonen van directoryinhoud zou ook standaard aan kunnen staan in de apache webserver, maar blijkbaar is dat bij @home/ziggo dus niet zo)
     
  7. Je kan toch gewoon een .htaccess bestand gebruiken met de regel Options -Indexes
     
  8. Dat werkt blijkbaar niet (kan dat niet testen, want ik zit niet in @homegebied), maar volgens oudere handleidingen die bij troublesathome.nl te vinden zijn zou dat niet werken/uitgeschakeld zijn.
     
Niet open voor verdere reacties.

Deel Deze Pagina